Dungeon Defenders 2 Bug Reporting

Items bugging out after unequipping (Windows)
Items will disappear after unequipping
Repro Chance: 100%
Steps for Bug Repro:

After unequipping a relic it says it was moved to bag 1

the relic is not in any of the bags after searching and ends up with the scavenger

I retrieve it from the scavenger but when it ends up in my bags and i try to equip again it disappears

Sometimes it won't disappear but will sit in the bag slot and not register at all to be able to use it.

until I relog and it ends up with the scavenger again.

Expected Results: Expecting to be able to switch out my relics and shards to other heroes to alter my deck

deadpplqq posted this bug on06/20/18
ItWasLikeThatWhenIGotHere 06/20/18 16:39


Yeah we were able to repro this using your profile. We'll try to figure out whats wrong with the item(s) and hopefully get a fix out soon. Thanks!

LEGACY 06/21/18 16:44

This exact bug is disrupting my gameplay as well--can't move shards in game.

Nulx 06/21/18 17:15

Happening to my account as well. Please help. 

deadpplqq 06/23/18 04:09 @7030

Thank you for looking into it I do hope there is a fix soon too as I have lost almost all of my upgraded relics and equipment.

Subito 06/27/18 22:34

Having the same issue

Stoya 07/02/18 13:53

I have the same bug. Totem has gone.

arvinzen 07/09/18 00:06

My Relics Gone when i unequip my relics hope you can give back my relics


Kithron44 07/09/18 21:40


Today i was playing a match and i unequipped 1 relic and 4 shards.  After i unequipped i looked throughout my entire inventory and couldnt find them anywhere.  The shards were the only copies that i had, and the relic that i took off was my best relic, i was really stressing out about this.  I looked in the scavenger and i saw only one shard in there and nothing else.  Please help me i really need that stuff back.

Soup 07/19/18 04:05

Same thin also happend to me plz help me get my stuff back, build kinda needs it. ty


Zkanor 07/23/18 20:33

I have a big problem I have to remove all the shards from my heroes and I lost everything, I could not equip and go back to scavanger all the time I restart the game and I lost everything, shard deadly stricke, destruction, defense rate and mod tenacity 5/5 !
Help please!


Edited on: 07/23/18 20:37
Benz 09/19/18 04:40

I have the same bug. Totem has gone.


WishpeR92 09/28/18 12:46

i lost all my gear from my main char, uninstalling the game unplayable, the game is all about grind and then u lose everything that u hardwork on, not recommend this game to anyone

giannaras666 10/23/18 20:08

hello  my name is giannaras666 in game  my helmet dissspeared after i unequiped it can we found a solution ?  it was really good helmet

kabdelgh 11/03/18 14:52

happens to me as well except glitches out while in the scavenger slot then just disappears forever. Happened to me with 2 of my favorite legendary items.....

Skydubbbz 11/07/18 16:13

I just finished a game of onslot with a full inventory and when I got to the town I lost over half my inventory, including my best polearm.

I don't know what caused this, but it cost me quite a few hours of progress.


Venom0usX 11/29/18 04:24

I have the exact same issue and this has resulted in my gilded shards in the Scavenger with a 30 minute decay timer when i unequip them from a defence. I found this to be heavily associated with latency issues. Not sure if anyone else here experiencing this bug also experiences the summary screen bug where the Summary screen will NOT appear when you G after getting the chest, making you unable to replay the map.

Edited on: 11/29/18 04:25
Issofresh 12/06/18 03:19


im missing my relict, i autoequipped some new relicts and now its gone.

On the relict was +CC dmg , the Stun of the weapon manufactur ( ev2 ) and attack rate.

Could you help me?

rocknrollpyro 01/14/19 01:40

this bug happened to me to I had a demon scythe equipped to my abyss lord and I used auto-equip and it disappeared from my inventory all together, but I later found it with the scavenger but it was glitched out and only visible when I clicked claim all.

mrv ah 01/18/19 00:49

Same thin also happend to me plz help me get my shard please my best shard 

Bug Hunter Ev 3 02/27/19 19:59

My item drop from a stats of 39k tower attack to some shit stats 300 something I waste 11 ruby to upgrade that medellion. Because its bug it even after i spend ruby it say i need to spend more ruby to upgrade so i just spam click until i ran out of ruby and the item did not upgrade.

Dance Fire 04/13/19 13:55

My Monk polearm with DK frost aura is gone. I auto-equip gear like usual and usually is there. But this time it's gone! Please return it. Thanks!


Bailyrepluse 04/20/19 18:09

I lost my frostbrand like this. Please fix and return my weapon?? 

Lrsen 05/31/19 14:06

Just lost my hyper shard "Mass Destruction" to this super annoying bug. And i cant even regrind the shard cuz its a hyper shard .... Please fix Trendy/Chromatic. This bug is pretty game breaking, if you can lose hyper shards.

Edited on: 06/11/19 13:20
Empty_Nation 08/15/19 04:22

Just lost, 2 deadly strikes, 2 destruction, mass destruction and I've lost 4 defense rates, been a long time still no fix, like come on, you're just losing players at this point.