Dungeon Defenders 2 Bug Reporting

EV2 Proton Charge Crashes Game for Entire Group (Windows)

During the course of waves, when EV2 overheats using the proton charge ability, the entire map starts crashing.  Enemies start walking in straight paths off the field and into the air, and after 10-15 seconds the entire game crashes.  This affects not just my game, but also anyone else in the party with me.  It has happened about a dozen times now, and I just figured out that it has always been at the exact moment she overheats and auto transfers out of her "turret" stance.  I then went into another map with the same friends and tested it.  After about 20 attemps at the overheat, the game crashed as it had before.  I have never seen this with any other character or ability to the best of my knowledge.

Concept9 posted this bug on11/06/16
Petire 11/09/16 19:08

A few people have reported this now, I have been unable to reproduce this issue both solo or in a group, if you have any other information in to what is causing this. Specific passives or hero combinations or pet combinations. Party status, server status or what map you are playing on. Thanks!

RoseCrime 11/09/16 20:46

Seen it few times,but thought it's cause of host's internet connection.
You don't get information how enemies moving and they're just keep going same way as before,even throught walls and in air....and after it kicks you into main menu(right?)
Seen it even without proton charge usage.Bastile Master incursion the only map i remember.

Thyraxx 11/17/16 07:24

I've been able to reproduce it a few times, but it's quite difficult, i've send an error log to trendy regarding this problem, so I hope this error can be fixed soon.

waywardKing 11/27/16 04:46

I've had this happen multiple times. The crash occurs when leaving 'siege mode' in the Proton Charge ability. For me, it has happened when I leave siege mode just shy of overheating: In my case around 195 out of 200 heat due to spheres.

All enemies and other characters drift in straight lines, EV2 remains stationary. The host connection is lost, and all players in the match have to exit and relaunch the game before they can connect to a private tavern or the town.

waywardKing 11/28/16 21:42

Had it happen again, this time on a character with 100 heat capacity, and when I reached maximum heat, without any chance or attempt to exit siege mode.

Thyraxx 02/15/17 07:54

Yea, so I tested it again today, I removed everything: I unequipped items, resetted my stats and removed all my spheres, and I can still reproduce this bug.

Ggmdark 03/01/17 20:00

Yes. It happens from time to time, and it's always when EV2 finishes using the '3' ability.

This is when the bug occurs.

Then, the game shows this window.

And this is the window whenever you try to go back to the tavern.

(Also, it has been more frequent in this new update).

Edited on: 03/01/17 20:03
Ruinous 03/02/17 06:34

This is still occurring in the Trials update. I have had it happen to me several games consecutively, on different maps. A friend of mine has also had it happen on his EV.

As others have reported, it occurs once EV hit's max Heat while using Proton Charge. It does not occur in the Private Tavern, I have not tested Public.

Zoot 03/02/17 08:33

ive also been getting this bug makes my ev unplayable

SexyChaika 03/04/17 22:42

What @Ggmdark said, also it happens in the Private Tavern too, hope you'll be able to fix this :/

Just happenned again without hitting heat cap

Edited on: 03/05/17 09:20
SexyChaika 03/05/17 10:28

Can't use the best DPS out of fear that'll time out... 

Happenned again a few times, only solution is to wait for EV.3 ... 

Thyraxx 03/05/17 13:55

Yep, today only, I already experienced 3 EV2 crashes, 1 by my friend, and 2 times by myself, which were all accidental, it certainly has to do something with the heat and the Proton stance. I reported this bug  once with some debug logs, maybe more people need to do that


Maybe if more people try to reproduce this bug and send their logs to Trendy they will be able to find what causes it?

Any specifics: EV2 only afaik, doesn't matter which or what passives/gear/level/map/public or private.

Edited on: 03/05/17 13:56
Nerva 03/07/17 17:48

I can confirm that this is happening.  If EV-2 overheats while using Proton Charge, the game disconnects everyone playing and returns to the title screen.

Party Combination (Bolded entries are the characters being used at the time of disconnect):

  1. EV-2/Dryad (Host)
  2. Lavamancer/Abyss Lord (Me)

Defenses Used w/Noteworthy Shards:

  1. Skeletal Ramsters x6 (Deadly Strikes)
  2. Skeletal Archer x2 (Rain of Oil)
  3. Moss Hornet's Nest x3
  4. World Tree x1
  5. Maw of the Earth Drake x3 
  6. Fissure of Embermount x3 (Magma Maelstrom)

Map: Unholy Catacomb (Randomly selected by Chaos 1 Trial), occurred on Wave 5 (final).

Situation: I was standing on the Crystal, using Direct Command to conduct my Ramsters and Archers.  EV-2 was dealing with Tuskar, and had been using Proton Charge to obliterate the last of his health when she overheated and the disconnect occurred.

Any other information that should be provided?

Edited on: 03/07/17 17:51
z3rO 03/11/17 16:43

Have any of you by chance were trying to exit the Siege Mode the instant you overheat when you crash?
That is the most semi-consistent way I have been able to reproduce the bug, although still it doesn't work every time.

Nickolai1989 03/12/17 04:13

I have actually tried to exit out of siege mode the moment that I overheated....but when me and my friend tried it and allowed it to take us out of the mode itself it didn't crash. That would make sense because I usually try to exit out of siege mode early due to me being afraid that I would crash my game....I hope that is the case because I like EV2 as an active dps not because of the way her damage numbers  are...but because with her skin being a reference to Metroid XD but in response to the topic...yes...I have had this happen a few times but only when I try to exit out of siege mode myself when I was overheated.

Thyraxx 03/16/17 13:03

For the developers and us, what we know so far:

What doesn't matter->

  • Level
  • Map
  • Gear
  • Shards/Spheres
  • Pets
  • Any other skills besides the Proton stance.

What does matter->

  • Amount of heat (Max heat)
  • Most likely the moment you get out the proton beam stance
  • Hard to reproduce.

I'll turn on debug mode again and send the logs to Trendy, again... xD If neccessary, I even have a few crashes recorded and uploaded them to youtube a few months ago, I could post them, if asked.


Edited on: 03/16/17 13:03
o__0 04/01/17 18:57

This bug still exist, it happen to me about twice on 3 skills.... How to say it's a "few" boring ? Bug is know since some months now, and seems like developpers make any try to resolve it. That puff me off buying EV2

Edited on: 04/01/17 18:58
Depova 04/14/17 21:43

I can confirm this bug is definitely still a problem.  I reproduce it every day.  Crashes it for the entire party.  I'm always fighting a boss and have the dracolich on cooldown most of the time but I don't think that matters based on what everyone else is experiencing.  It seems to be happening much more frequently since the trials patch.

Depova 04/14/17 21:58

I can now also confirm this happens in town as well....  Don't know if it caused others to crash out either but I definately got my game to crash at around 9:50 est time.  A few others said they crashed at the same time and I was not able to get into town for a few minutes even after restarting the game.  Wanted to give you the time just in case I inadvertantly crashed something with my testing.

capnemo314 04/21/17 01:47

Still an issue as of the Spring Forward update.

MrBlack 04/26/17 12:24

Confirming this is still happening even today at : 4/26/2017  9:46 am

Crow08 05/16/17 14:54

Here is a extract from the logfile when this problem occurs:


(20:29:35:155)Log: [Ability]DunDefPlayerAbility_ConsumesFire: Activated 'ProtonCharge' owned by DDPC_Coop_1 instigated by DunDefPlayer_11
(20:29:44:054)Log: [Ability]DunDefPlayerAbility_ConsumesFire: Completed 'ProtonCharge' owned by DDPC_Coop_1 instigated by DunDefPlayer_11
(20:29:54:005)Log: [Ability]DunDefPlayerAbility_ConsumesFire: Activated 'ProtonCharge' owned by DDPC_Coop_1 instigated by DunDefPlayer_11
(20:30:15:014)DevNet: Error: Can't send function 'ServerMoveExWithLook' on 'DDPC_Coop_1': Reliable buffer overflow
(20:30:15:020)DevNet: Error: Can't send function 'ServerUpdatePlayerWantsToMove' on 'DDPC_Coop_1': Reliable buffer overflow
(20:30:15:025)DevNet: Error: Can't send function 'ServerSetAutoAimTarget' on 'DDPC_Coop_1': Reliable buffer overflow
(20:30:15:026)DevNet: Error: Can't send function 'ServerMoveEx' on 'DDPC_Coop_1': Reliable buffer overflow
(20:30:15:036)DevNet: Error: Can't send function 'ServerClearAutoAimTarget' on 'DDPC_Coop_1': Reliable buffer overflow
-- the same 5 errors repeat over and over (1500+ lines of errors) --
(20:30:25:017)DevNet: Error: Can't send function 'ServerUpdatePlayerWantsToMove' on 'DDPC_Coop_1': Reliable buffer overflow
(20:30:25:021)DevNet: Connection timed out after 22.000000 seconds (22.002925)
(20:30:25:026)NetComeGo: Close TcpipConnection_1 05/16/17 20:30:25
(20:30:25:026)PlayVerse: -=-=-==-== WEBMETHOD CALL -=-=-==-==: Matchmaking::LeaveMatch
(20:30:25:026)PlayVerse: METHOD PARAMS:
(20:30:25:030)Log: URL: Adding default option name=someone@trendyent.com
(20:30:25:030)Log: URL: Adding default option team=255
(20:30:25:030)MatchMaking: Browse: DunDefEntry?closed?name=someone@trendyent.com?team=255
(20:30:25:030)Log: Failed; returning to Entry
(20:30:25:039)Log: LoadMap: DunDefEntry?closed?name=someone@trendyent.com?team=255
(20:30:25:209)Exit: UTcpNetDriver shut down
(20:30:25:272)Log: Game class is 'Main'


Seems like an buffer-overflow.

I hope this information is helpful.

ConnorM 05/25/17 17:01 @3704

Would it be possible to get the complete log file?

If you could just upload the text file somewhere that would be great.

You could also submit the log to our Customer Support team at http://support.trendyent.com.

Edited on: 05/25/17 17:33
haruki6669 05/26/17 12:33

This is a problem on ps4 as well. Happens every time i fail to exit siege mode before hitting 100 heat.

Thyraxx 05/30/17 14:18 @3795


I've already sent those logs half a year ago to logs@trendyent.com , but will be sending the logs again to support@trendyent.com (edit: woops wrong email?). Hope it could be of any use :)

Edit: It seems like your support link is not working?

Edited on: 05/30/17 14:27
Thyraxx 05/30/17 14:30

Woops, don't mind the message above, http://support.trendyent.com is working, I accidently copied the dot at the end.

Crow08 05/30/17 17:53

Here is a download link for the full log file:


XxRozayxX 06/26/17 15:22

Xbox one This bug is still going on. In a 5 wave match if you use the beam it well crash the game. Looking at it now it seems when the beam gets to 100% heat or near it the bug takes effect. I also notice only happens in (The 6 times i did it. All crashed) I was shooting a beam at a group of enemies or boss holding it for awhile. 

After words the game would crash for everyone and the enemies would fly away going on their path like said above. This happens 9/10 (I had 10/10) It happens every time i have a full group and i use the beam during the 5 wave mission. Some times it happens round 2 or well happen in 5 but before the 5 round is done it crashes. 

The huntress 07/07/17 10:00

I've never seen this before. I use ev2 extremely often and I often just use proton charge till I overheat it's my strategy but that never happens for me I just primary attack until I can do it again.