Dungeon Defenders 2 Bug Reporting

Rain of Oil shard does not work. (Windows)
Rain of Oil does not apply oil to enemies in any circumstance. To make sure that this wasn't caused by interactions with other mods or equipment, I removed all equipment except a weak medallion with only the Rain of Oil (20/20) shard in it and here is a .gif of the result in a campaign tier map: https://gfycat.com/WelldocumentedLonelyCaterpillar As you can see, the enemies hit by the Skeleton Archer's Direct Command are not oiled nor slowed. Rain of Oil also (and more irritatingly) does not allow damaging of controlled burn waves, as can be seen in the following .gif: https://gfycat.com/ShinyAptDromaeosaur I've had a second player with the shard also test this, and it does not work for them either.
Repro Chance: 100%
Steps for Bug Repro:

Equip the shard, use the direct command ability.

Expected Results: Enemies are neither oiled nor slowed.

Piddagoras posted this bug on10/23/18
Piddagoras 10/23/18 15:44

The gifs are at the following urls:

The shard not working in controlled circumstances (no other equipment, mods, or shards):


The shard not working against a Controlled Burn wave under normal use:


ConnorM 10/23/18 17:01

It is correctly oiling enemies hit for me, even when using an exact duplicate of your profile changing nothing.

ConnorM 10/23/18 17:01
Thanks for your bug report! We've investigated your report and followed your instructions, but we were unable to reproduce the bug on our end.

Being able to successfully reproduce a bug is critical to the process of bug fixing. Without a successful step-by-step list of instructions to get the bug to happen, we won't be able to fix this bug. If you (or anyone else reading this) have any additional information that could lead us to successfully reproduce this issue, please reply to this thread. If we do not receive any additional information, we will close this report in two weeks, and you will need to resubmit the report once you have new details that could lead to a successful repro of this bug.

Thanks, and we look forward to hearing from you!
Piddagoras 10/24/18 19:50

Thank you for your response.  I wish i had more information on how to reproduce this bug, unfortunately I have the opposite problem: that I cannot get the shard to work at all.  I don't particularly care about being right that it isn't working, and I would prefer to just have it work.

The only possibility I can think of, right now, is that perhaps it doesn't work on live servers but works in your testing environment for some reason (I can't imagine what would cause this).  Like I said I've had at least one other person use the shard with the same result: enemies weren't oiled.  I also recently found a second copy of the shard and confirmed that it also doesn't work when using an un-upgraded shard.

Again, thank you for your time and I'm sorry I can't offer more to help fix this.

Piddagoras 10/24/18 19:56

So I realized there was some other circumstance I could test.  I recently made a second Abyss Lord card so I could specialize in various towers, and I decided to try using Rain of Oil on the other Abyss Lord, and it worked.  I have no idea why.  I'm going to do some extra testing to see what the problem might be, but currently, the shard seems to work for the Ramsteroni Abyss Lord, but not the Yog-Sothoth.  I haven't had a chance to test whether it matters only which Abyss Lord placed the tower, or which one casts the Direct Command, I rushed back to the Bug Report dude to put down a comment.  If I find out more I'll let you know.

Piddagoras 10/24/18 20:09

Ok, so I've gotten it to successfully on the second Abyss Lord only twice (and never on the first).  It seems to work only inconsistently, but at least I've seen it work, so I know I'm not just missing the visuals and being an idiot about it.  

The second time I got it to work, I hero swapped then swapped back and it no longer worked.  Because of this I thought it was related to hero swapping after dropping the skeleton archers, but that doesn't seem to be the full story, since I haven't been able to get it to work a third time on either Abyss Lord.  I'll post any further results here.

Piddagoras 10/24/18 20:25

I believe I've successfully found conditions under which the Rain of Oil shard can be made to work.  To reproduce it working:

1. Place a Skeleton Archer

2. Unequip and Re-equip shard

3. Direct Command


It seems to always fail after switching heroes after placing the archer, but the only circumstances which I seem to be able to consistently guarantee that it works are those above, so I'm not sure that this is the only way to break it.  It seems to me that somehow the Rain of Oil shard is "forgotten" after some number of things occur, including hero swapping, but possibly other things, since when I was testing in general, I did not swap heroes, but the shard still didn't work.

Hopefully this helps.

Piddagoras 10/24/18 20:43

Ok, I think I've isolated the problem.  To get it to fail, simply swap heroes any time after entering the map before casting Direct Command.  It appears to work fine if you have never swapped heroes after entering the map or if you re-equip the shard after swapping (and don't swap again).

Apparently I've never used it without swapping before, and so it never worked.  Sorry it took so many comments to isolate this fact.  Hopefully this helps you reproduce the bug.