Dungeon Defenders 2 Bug Reporting

Tinkering failing. Waste of medals and precious mods. (Windows)
Sometimes it works, sometimes it doesn't which is very annoying. Basically, in the town I was trying to add a 3/5 defense rate mod to my new medallion. The end result was i lost crafting materials and medals as expected, but the mod DID NOT end up on my new gear as desired. In fact, the original item disappeared too so it was a complete lose-lose situation. Something that might be worth noting is that the item I tried to add this mod onto was upgraded from mythic to legendary. I have a hunch this might be the culprit, as that forces an extra mod slot onto the item and that was the slot where I tried to tinker. Just a hunch though.
Repro Chance: 50%
Steps for Bug Repro:

1) Go to town

2) Tinker as usual (literally just normal steps, nothing fancy)

3) You lose crafting items, defender medals, and the original item; the mod is NOT on the new item.

Disclaimer: Again, as mentioned above, I SUSPECT this has to do with the 3rd slot that was forced onto my item when upgrading from mythic to legend.

Expected Results: 1) Go to town 2) Tinker as usual 3) Actually have the desired mod on my new item.

Aurasphere posted this bug on06/24/18
Aurasphere 06/24/18 12:57

Ok after some messing around I'm very convinced that this has to do with upgrading a mythic to a legendary. Since mythical items have 2 mod slots whereas legends have 3, when you upgrade your item an extra slot is added. This extra slot it seems is dysfunctional as of now. I can mod without any error on any other gear, but it seems that the 3rd slot of a legend that was upgraded from mythic is currently busted. Please fix this asap, Trendy!

Aurasphere 06/26/18 23:29

UPDATE: so i've been asking around and other people do not seem to have this problem. Lots of my friends have upgraded mythicals to legends and have modded successfully in the additional slot. Therefore, here's my *NEW* theory: I happened to purchase my relic from another player (as a mythical) before i made it legendary. THEN I tried modding the third slot, and it didn't work: therefore, I'm guessing it has to do with the player market system as mythics you find my yourself (and upgrade) don't seem to have this problem

ConnorM 06/27/18 18:41

The issue is any mod slot that gets added via advancing doesn't fully accept the new mod that was moved. Keep the items around that you tinkered with as I believe it will work fix all of their current states when we release the fix with the next update.

Edited on: 06/28/18 10:57
Aurasphere 06/27/18 20:01 @7151

Thanks you so much for the reply! Can I ask for clarification as to what exactly was the issue? Items modded via what?

ConnorM 06/28/18 10:59 @7158

I accidentally a word. Any tinkering done into mod slots that were added via advancing an item had the issue.

Aurasphere 06/29/18 00:41

Alright thanks! Has this issue been resolved? I saw Lawlta posting somewhere that it shouldn't be an issue anymore. I want to mod a relic that has been upgraded but I'm scared I might lose the mod...

ConnorM 07/02/18 17:07

Nothing has been resolved yet. Will be in the next update.

Note to everyone there are also issues with placing mods onto items after Upgrading/Evolving them. This has mostly been observed on Protean weapons. Might be best to hold off on tinkering until we push a fix if it is something you can't stand to lose.