Dungeon Defenders 2 Bug Reporting

20
Votes
Scavenger "Claim All" button doesn't work (Windows)
When the scavenger has items to be recovered, the "Claim All" button remains dimmed out and the items can only be acquired by right-clicking each one.
Repro Chance: 100%
Steps for Bug Repro:

Pick up too many items.

Visit Scavenger (in Private Tavern in my case).

Try to click "Claim All".

Expected Results: Claim all button functions.


SupaFly posted this bug on06/21/17
SupaFly 06/22/17 01:44

Sent a few more items to the scavenger and am unable to 'Claim All' (button is grey rather than what used to be blue if I recall correctly).

Thought it might be because some of my bags were full, so I made sure there was enough room in every bag to hold the scavenged items.

Played around with the auto-collect and auto-sort setting on all the bags.

Tried the scavenger in town as well as the private tavern.

Tried restarting the game.

Nothing seemed to enable the 'Claim All' button.  I'm leaving a item in there to expire to see if that somehow corrects things, will check again tomorrow.  Other than that I'm out of ideas for today.

SupaFly 06/22/17 01:52

Also, I thought the scavenger has an ! icon over his head if he has an item to claim.  Mine does not.  Unsure if that is related, a seperate bug, or maybe the icon is only there until you open his inventory (don't usually close his interface and leave the items on him).

JZsweep 07/06/17 19:25

I've not had this issue

Dr.Shadox 07/11/17 14:31

I have this issue too , even with only 1 item in Scavenger window , and with plenty of free space in my bag.

Sonny6155 07/15/17 07:32

I can confirm that I had this issue since I first started playing about 2 weeks ago, and still currently so. I'll try to assist in confirming and replicating this bug.

Jesus is Lord 07/17/17 16:29

for the record, i also have this bug - the "claim all" button has never worked for me ( and i use the scavenger quite often ). 

Glass of Milk 08/17/17 16:30

This bug is pretty annoying, espicially when you farm chaos and a lot of stuff goes to him.

jobetoco94 08/21/17 12:24

all players have this bug